how to update Kali Linux and Fix update error

Kali Linux’s the great Penetration testing system is like any other system in the world it need to be updated,
Most of the update is not by Kali Linux team, most of the update is by the tools programmers...

By those smart guys who made the great tools you can find in Kali Linux
So we have to update Kali Linux to keep the tools in functional order.
This short tutorial will show you the command to update the tools and system.
What you will learn in this tutorial is
1- how to update Kali Linux
2- how to fix update errors
3- how to update Kali Linux on a network that has a proxy

First you can check this youtube video


So let's start !
Step One:
Start Kali Linux and open a terminal.

Step Two:

Type apt-get update && apt-get upgrade 
in the terminal and hit Enter.
Now everything should work fine and the update will start ...
But what if you got some wired errors...

2- Fix Kali Linux Update errors

Type apt-get clean && apt-get update && apt-get dist-upgrade
Still having the problem ? maybe some package is missing ?
for that type


apt-get update --fix-missing
Then type
 apt-get update && apt-get upgrade
Still not working?
Now we have to check our  sources.list file .. For that i made a post check
 Fix Kali Linux sources.list Repositories
So after all its not working ?
Maybe you have a proxy in your network ?
So here is the fix
Update behind proxy type

Type : sudo apt-get install proxychains
Type : add proxy to /etc/proxychains.conf then
proxychains apt-get update && apt-get upgrade
....
Hope its working now and you got your system updated but if not then leave a comment with details about the error.
 You can check this Video 

update Kali Linux
Kali Linux Fix update error

how to update Kali Linux and Fix update error kali linux rolling repository kali linux e unable to locate package

Labels:

Post a Comment

  1. root@lulzsec:~# apt-get update --fix-missing
    Hit:1 http://par-epistemen-taksis.de/kali kali-rolling InRelease
    Reading package lists... Done
    W: No sandbox user '_apt' on the system, can not drop privileges

    :-? :-? :-? :-?

    ReplyDelete
    Replies
    1. the problem is with the source url
      ( http://par-epistemen-taksis.de/ )
      503 Service Temporarily Unavailable

      Delete
    2. bash: /root/.bashrc: line 112: syntax error: unexpected end of file
      what is this error in terminal ? please help me sir!

      Delete
  2. Trying to update my kali 1.0 to kali 2.0
    It says(Excuse for my kali is in french version):
    W: Erreur de GPG : http://security.kali.org sana/updates Release : Les signatures suivantes ne sont pas valables : KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400
    W: Erreur de GPG : http://http.kali.org sana Release : Les signatures suivantes ne sont pas valables : KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400
    W: Impossible de récupérer http://security.kali.org/kali-security/dists/kali/updates/main/binary-amd64/Packages 404 Not Found

    W: Impossible de récupérer http://security.kali.org/kali-security/dists/kali/updates/contrib/binary-amd64/Packages 404 Not Found

    W: Impossible de récupérer http://security.kali.org/kali-security/dists/kali/updates/non-free/binary-amd64/Packages 404 Not Found

    E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

    What can i do?

    ReplyDelete
    Replies
    1. what you have in your sources.list ?
      check this post

      Fix Kali Linux sources.list Repositories
      http://kalitut.blogspot.com/2014/06/fix-kali-linux-sourceslist-repositories.html

      Delete
  3. i was try but my kali linux 2.0 still error... can u help me mr.walid.... i hope u can help me.... thanks before mr.walid

    ReplyDelete
    Replies
    1. whats the error your getting pleas post it here

      Delete
    2. bash: /root/.bashrc: line 112: syntax error: unexpected end of file
      this error in terminal. how to fix it sir

      Delete
  4. sorry bro i have a problem in this order, please solution

    #sudo apt-get install mac-os-lion-theme-v2
    Reading package lists ... Done
    Building dependency tree
    Reading state information ... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    mac-os-lion-theme-v2: Depends: GTK3-engines-unico (> = 0.1.0 + r79) but it is not installable
    E: Unable to correct problems, you have held broken packages.

    thanks

    ReplyDelete
    Replies
    1. the Repositories for this them (Mac OS X Lion Theme) didn't come with the fresh IOS of kali so you should try to contact the them maker they should know whats the problem you are having

      Delete
  5. thank you so much this is the only thing that has worked to get my kali updated so i can get my headers from 4.3 to 4.4 now i can finally get guest additions working thank you so much!!!!

    ReplyDelete
    Replies
    1. same here! finally got guest additions up and running thanks to this.. thanks so much!

      Delete
  6. This comment has been removed by the author.

    ReplyDelete
  7. root@l4young:~# sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
    fonts-droid gtk2-engines inguma libasn1-8-heimdal libbasicusageenvironment0 libbind9-90 libdns100
    libgroupsock1 libgssapi3-heimdal libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal libheimntlm0-heimdal
    libhx509-5-heimdal libilmbase6v5 libisc95 libisccc90 libisccfg90 libkdc2-heimdal libkrb5-26-heimdal
    liblivemedia23 liblwres90 libntdb1 libopenexr6v5 libpgm-5.1-0 libpth20 libpython3.4-minimal
    libpython3.4-stdlib libqmi-glib1 libquvi-scripts libquvi7 libregfi0 libroken18-heimdal libsodium13 libsysfs2
    libtrio2 libusageenvironment1 libwind0-heimdal libx265-68 libzip2 libzmq3 python-bluez python-characteristic
    python-dbus-dev python-geoip python-ntdb python3.4 python3.4-minimal ruby2.2-dev
    Use 'sudo apt autoremove' to remove them.
    The following packages will be upgraded:
    bleachbit exploitdb
    2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 22,0 MB of archives.
    After this operation, 2.699 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 bleachbit all 1.10-1 [293 kB]
    Err:2 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 exploitdb all 20160414-0kali0
    Connection failed
    Fetched 293 kB in 4min 12s (1.160 B/s)
    E: Failed to fetch http://kali.mirror.garr.it/mirrors/kali/pool/main/e/exploitdb/exploitdb_20160414-0kali0_all.deb Connection failed

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


    i try

    I 've tried every way that you taught, but have not been successful

    ReplyDelete
    Replies
    1. the problem as i see it on this mirror
      http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 exploitdb all 20160414-0kali0

      so did you fix your sources.list Repositories ?
      check this post

      http://kalitut.blogspot.com/2014/06/fix-kali-linux-sourceslist-repositories.html

      Delete
    2. Software update >install updates>1831 updates selected >
      Then it pop-up as failed to process request

      Delete
  8. This comment has been removed by the author.

    ReplyDelete
  9. In kali linux newest one for raspberri 2. still got this errors:

    Err:1 http://http.kali.org/kali sana InRelease
    Temporary failure resolving 'http.kali.org'
    Err:2 http://security.kali.org/kali-security sana/updates InRelease
    Temporary failure resolving 'security.kali.org'
    Reading package lists... Done
    W: Failed to fetch http://http.kali.org/kali/dists/sana/InRelease Temporary failure resolving 'http.kali.org'
    W: Failed to fetch http://security.kali.org/kali-security/dists/sana/updates/InRelease Temporary failure resolving 'security.kali.org'
    W: Some index files failed to download. They have been ignored, or old ones used instead.

    ReplyDelete
    Replies
    1. download the latest source from aircrack-ng.org

      or type in terminal

      wget http://download.aircrack-ng.org/aircrack-ng-1.2-rc4.tar.gz
      tar -zxvf aircrack-ng-1.2-rc4.tar.gz
      cd aircrack-ng-1.2-rc4
      make
      make install


      Worked for me.

      Delete
    2. For some reaseon it works now! i use my pi with kali linux remote. I use RDP with the standard windows 10 remote desktop app. It works like a charm. But you can not login as ROOT. So i have a user given the rights root. I have the pi connected to a screen etc. to login and update from there, and then it works. Then i login in with the other user with root right, and update/upgrade works like a charm!!! iam happy with it. I remmember your notice for later.

      Delete
    3. Glad it worked for you and thanks Sarthak Mahajan for the support

      Delete
  10. This comment has been removed by the author.

    ReplyDelete
  11. This comment has been removed by the author.

    ReplyDelete
  12. As Salamun Aleykum Mr.Waled. I did everything you write in here. But it gives me an error like this :
    Running updmap-sys. This may take some time...
    updmap-sys failed. Output has been stored in
    /tmp/updmap.W2bx8HCY
    Please include this file if you report a bug.

    Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
    causes updmap-sys to fail. Please check for files with extension
    .dpkg-dist or .ucf-dist in this directory

    dpkg: error processing package tex-common (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of tex-gyre:
    tex-gyre depends on tex-common (>= 3); however:
    Package tex-common is not configured yet.

    dpkg: error processing package tex-gyre (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-fonts-recommended:
    texlive-fonts-recommended depends on tex-common (>= 3); however:
    Package tex-common is not configured yet.

    dpkg: error processing package texlive-fonts-recommended (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-fonts-recommended-doc:
    texlive-fonts-recommended-doc depends on tex-common (>= 3); however:
    Package tex-common is not configured yet.

    dpkg: error processing package texlive-fonts-recommended-doc (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of tipa:
    tipa depends on tex-common (>= 3); however:
    Package tex-common is not configured yet.

    dpkg: error processing package tipa (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    tex-common
    tex-gyre
    texlive-fonts-recommended
    texlive-fonts-recommended-doc
    tipa
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    ReplyDelete
    Replies
    1. hi Eliheyder Qubatov sorry for being late /....
      if you still have this error pleas post the report on Kali Linux TroubleShooting Forums
      https://forums.kali.org/forumdisplay.php?13-Kali-Linux-TroubleShooting

      Delete
  13. is there an 5ghz adapter that can deauth accespoints? and works on a raspberri pi 2 with kali linux

    ReplyDelete
    Replies
    1. thanks, i have already ordered it. Only it is version 2. Is that good or bad? the older version is hard to get. Chipset is RT3572 Hope it is true.i have ordered this anntenna: Alfa APA-M25 I hope it workes like a charm!

      Delete
    2. i just received it, but i always use websploit and the module wifi/wifi_jammer It works not on that. What command to use to scan 5GHZ networks, and what command to DEAUTH 5ghz accespoints?

      Delete
    3. about scanning 5GHZ networks it can be done by airodump-ng
      but i my self didn't work with 5GHZ before ... i will try to tast it as soon as i get time ...
      about the adapter version 2 should work fine never heard any bad review about it . will now you have it try it and let me know , :) i will be waiting to hear from you

      Delete
    4. airodump-ng wlan0mon --band a is the command to scanning 5ghz networks. You can also use: airodump-ng wlan0mon --channel 36 for example. That works, but i looking the whole day for a deauth command. Google give me no more information. I think it can not. tried with wifislax too, but there is no script/program for 5ghz :S If someone can help me out? i need only script/program for deauth accespoints.

      Delete
    5. anybody a command to deauth 5ghz accespoints?

      Delete
    6. i'm trying to find but not yet ,,,

      Delete
  14. i was trying to update my kali linux but still not working

    ReplyDelete
  15. anybody a command to deauth 5ghz accespoints? i use now on a laptop WIFISLAX and the tool: accespoint fucker then option 7 deauth. only fill in the MAC of the accespoint and the channel. and then it deauths i guess... but i have no 5ghz router :D Can anyone check this for me?

    ReplyDelete
  16. just bought a asus ac66u but the 5ghz deautch commands are not working.
    @Walid Salame you said it can, but how? i tried everything. Wifislax also not deauth 5ghz

    ReplyDelete
    Replies
    1. sorry where did i say the asus ac66u can do the job ?
      and can you give me a link to the product you bought ,, did you bought a router or a wifi adapter ?

      Delete
  17. see 2may 2016:

    ME: is there an 5ghz adapter that can deauth accespoints? and works on a raspberri pi 2 with kali linux

    YOU:
    Walid SalameMay 6, 2016 at 9:06 AM

    yes this adapter dose the Job
    Alfa AWUS051NH 802.11a/b/g/n high power2.4GHz and 5.8GHz

    ReplyDelete
    Replies
    1. okay this is Alfa AWUS051NH not asus ac66u

      Delete
    2. you can not deauth 5ghz with the Alfa AWUS051NH. I have bought an asus ac66u but it doesnt work. Also with other 5ghz devices.

      Delete
    3. my friend the problem we have here is no one made a tool especially for 5ghz...
      don't bought don't get anything new for now you have to wait till someone come with the tool we need for 5ghz

      Delete
    4. i know it. but i dont know why you said it can with the Alfa AWUS051NH

      Delete
    5. the hardware of Alfa AWUS051NH support 5ghz... that's why i said it can do the job but still need the tools or some change on the code of old tools

      Delete
    6. yes it support 5ghz, that is why i buy it. But it can not deauth! i think it is communication :D

      Delete
    7. will we can only hope someone soon will find a way to make it deauth ;)
      maybe you should do it wie wat :P

      Delete
    8. Yes, i look every day for that. But i can not scripting myself :S

      Delete
  18. Good day!! Help me please!! When I start "besside-ng" I have a trouble. Besside-ng wi_read() No child processes. What does it mean? How can I fix it? I think maybe I need to update and upgrade Kali?

    ReplyDelete
    Replies
    1. ok lets start with updating and upgrading Kali linux and then try ....
      plus what wifi adapter are you using ?

      Delete
    2. So. I was updating for a 7 hours and could not wait anymore. I stopped update and switched it off. After I power on and typed "apt-get update --fix-missing". There was a problem and I typed dpkg --configure -a". It starts setting up. I don not know how much time my computer need to update. I think it is gonna be ok:-)
      P.s I using built-in notebook wifi adapter.

      Delete
    3. its seems you don't upgrade kali linux from long time and that's why it's taking that long ...
      anyway you did what you need to as i see and yes i should be working fine,
      about your wifi adapter i'm not sure if that can get you into wifi monitor mood and if it don't check my post about wifi cracking to see what wifi adapter you need

      Delete
  19. I have upgraded kali sana to rolling. Changes have been saved like Appearance. But still "uname -a" gives me older version.
    Linux Pythonlove 4.0.0-kali1-686-pae #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) i686 GNU/Linux
    And when I run "apt-get dist-grade" It downloads 2gb+ data again.
    #Help please

    ReplyDelete
    Replies
    1. did you receive any error at when you did the upgrade ?

      Delete
    2. Thanks for reply Walid salame. Now everything seems fine (I got firefox instead of Iceweasel and much more). But screen is flashing which is so annoying. Have you any solution please?

      Delete
    3. check your graphic card drives ,
      maybe updating the drives could fix the problem ,
      plus did you update and upgrade kali linux after upgrading from 2 to 2016.1 ?

      Delete
    4. Once I run dist-upgrade again everything is now fine. It did not upgrade completely that is why I was facing problems.
      And thanks for your positive response.

      Delete
    5. Can you please show me a process how to run chromium as root in kali 2016.1? Other methods wont work. Is there something changing?

      Delete
    6. you can get it to work from within a root user follow this commands

      1) useradd -m chro
      2) gksu -u chro chromium

      now it should work , this way your are runing it from a stander user but within the root

      Delete
  20. hello, i still get this:

    root@kali:~# apt-get update
    Reading package lists... Done
    E: Method http has died unexpectedly!
    E: Sub-process http received a segmentation fault.

    although i've update sources list. any idea?

    ReplyDelete
    Replies
    1. This is internet error , you are unable to connect to the sources
      check your internet gateway

      Delete
  21. Who know a good deauth command to a 2.4ghz AP ? If i use several command`s the whole street have no wifi. I just want 1 or 4 AP deauth completely. No other wifi point must be disturbed! I have the idea, when i deauth 2 or more AP the deauthing not correctly work. So you can deauth 1 AP with 1 adapter right? But i don`t get it when other wifi point disturbed when 1 only focus on 1 ap

    ReplyDelete
  22. how i fix ?
    E: Some index files failed to download. They have been ignored, or old ones used instead.

    ReplyDelete
    Replies
    1. did you tried to update over proxy ? if no then try this

      sudo apt-get install proxychains
      add proxy to /etc/proxychains.conf then
      proxychains apt-get update && apt-get upgrade

      Delete
    2. and if you did not fix your sources.list then check this post

      Fix Kali Linux sources.list Repositories

      Delete
  23. Who know a good deauth command to a 2.4ghz AP ? If i use several command`s the whole street have no wifi. I just want 1 or 4 AP deauth completely. No other wifi point must be disturbed! I have the idea, when i deauth 2 or more AP the deauthing not correctly work. So you can deauth 1 AP with 1 adapter right? But i don`t get it when other wifi point disturbed when 1 only focus on 1 ap

    ReplyDelete
  24. Are there solutions!
    root@kali:~# apt-get update --fix-missing
    Hit:1 http://kali.mirror.garr.it/mirrors/kali kali-rolling InRelease
    Traceback (most recent call last):
    File "/usr/bin/debtags", line 699, in
    main()
    File "/usr/bin/debtags", line 693, in main
    sys.exit(action.main(args))
    File "/usr/bin/debtags", line 637, in main
    for pkg, tags in self.tags_from_apt():
    File "/usr/bin/debtags", line 256, in tags_from_apt
    cache = self.apt_cache
    File "/usr/bin/debtags", line 241, in apt_cache
    res = self._apt_cache = apt.Cache()
    File "/usr/lib/python3/dist-packages/apt/cache.py", line 113, in __init__
    self.open(progress)
    File "/usr/lib/python3/dist-packages/apt/cache.py", line 164, in open
    self._cache = apt_pkg.Cache(progress)
    SystemError: E:Problem parsing dependency Conflicts, E:Error occurred while processing tmispell-voikko (NewVersion2), E:Problem with MergeList /var/lib/apt/lists/http.kali.org_kali_dists_kali-rolling_main_binary-amd64_Packages, E:The package lists or status file could not be parsed or opened.
    Reading package lists... Error!
    E: Problem parsing dependency Conflicts
    E: Error occurred while processing tmispell-voikko (NewVersion2)
    E: Problem with MergeList /var/lib/apt/lists/http.kali.org_kali_dists_kali-rolling_main_binary-amd64_Packages
    E: The package lists or status file could not be parsed or opened.

    ReplyDelete
    Replies
    1. Did you checked your sources.list Repositories ?
      Check this post if not
      Fix Kali Linux sources.list Repositories

      Delete
  25. anyone know a command to deauth 5ghz accespoints?

    ReplyDelete
  26. Please help me idk how many times ive had to reinstall. i ren apt-get update and it fetches the packages but then i get this

    Fetched 801 MB in 42min 0s (318 kB/s)
    Reading changelogs... Done
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    supported-versions: WARNING! Unknown distribution: kali
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2016.1
    setting xserver-xorg-legacy/xwrapper/allowed_users from configuration file
    dpkg: error: syntax error in file triggers file '/var/lib/dpkg/triggers/File'
    dpkg-query: error: syntax error in file triggers file '/var/lib/dpkg/triggers/File'
    update-kali-menu: error: dpkg-query gave error exit status 2
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    E: Problem executing scripts DPkg::Post-Invoke '[ ! -x /usr/share/kali-menu/update-kali-menu ] || /usr/share/kali-menu/update-kali-menu wait_dpkg'
    E: Sub-process returned an error code

    last time i did apt-get dist-upgrade it completely broke and ive yet to figure a way to stop the encrypted partition to not automount so i can reformat the usb -_-

    please please help this is a ridiculous amount of messing around to get a stable updated version of kali running. Yes my sources.list file is as it should be.

    ReplyDelete
    Replies
    1. you mean you tried to reinstall kali linux and after that you still get the same error ?? ?

      Delete
    2. if so , can you trying to install it in different drive like different USB and then try to update normally

      Delete
    3. and if you still able to load kali linxu
      you can try to do this and hope it will fix the error

      1)apt-get autoremove

      2)apt-get update && apt-get upgrade

      3)apt-get install libnet-daemon-perl libplrpc-perl memtest86+ syslinux-themes-debian syslinux-themes-debian-wheezy

      Delete
  27. I get,
    apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
    Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
    Hit:3 http://dl.google.com/linux/chrome/deb stable Release
    Hit:2 http://archive-7.kali.org/kali kali-rolling InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    ,

    Why is it looking for only chrome and not kali's fullrepo list?

    ReplyDelete
  28. is there already a program that can deauth 5ghz accespoints?

    ReplyDelete
  29. Thank very much for this post i finally got kali to update!

    ReplyDelete
  30. is there a way to deauth 5ghz?? i cant find it.

    ReplyDelete
  31. root@kali:~# apt-get update && apt-get upgrade
    Hit:1 http://deb.torproject.org/torproject.org wheezy InRelease
    Hit:2 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable
    xdman : Depends: openjdk-6-jre but it is not installable or
    openjdk-7-jre but it is not installable
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:~# apt-get clean && apt-get update && apt-get dist-upgrade
    Hit:1 http://deb.torproject.org/torproject.org wheezy InRelease
    Hit:2 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable
    xdman : Depends: openjdk-6-jre but it is not installable or
    openjdk-7-jre but it is not installable
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:~# apt-get update --fix-missing
    Hit:2 http://deb.torproject.org/torproject.org wheezy InRelease
    Hit:1 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease
    Reading package lists... Done
    root@kali:~# apt-get update && apt-get upgrade
    Hit:1 http://deb.torproject.org/torproject.org wheezy InRelease
    Hit:2 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable
    xdman : Depends: openjdk-6-jre but it is not installable or
    openjdk-7-jre but it is not installable
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

    ReplyDelete
  32. Hello, I really need help with this. Kali will not let me use apt-get install anything.

    Every time I try it I get these errors:

    The following packages have unmet dependencies:
    cpp-5 : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed
    cpp-6 : Depends: gcc-6-base (= 6.2.0-5ubuntu12) but 6.3.0-8 is installed
    g++-6 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    gcc-5 : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed
    gcc-6 : Depends: cpp-6 (= 6.1.1-11) but 6.2.0-5ubuntu12 is installed
    Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libasan2 : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed
    libasan3 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libatomic1 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libcc1-0 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libcilkrts5 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libgcc-5-dev : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed

    There are actually about 20-25 more but all requiring the same gcc-5 & 6 base files. I can't find any where to download and install those older versions. I've spent numerous hours on this.

    I've tried all the apt-get update && apt-get upgrade, apt-get autoremove, apt-get -f install, and everything else I can find online. I also have updated my sources.list to reference deb http://http.kali.org/kali kali-rolling main contrib non-free. I'm very new to Kali. I installed a bunch of deb files to get my wifi card working which it is now finally working.

    Please help me get my apt-get install working.

    ReplyDelete
  33. I have an error
    W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operation not permitted)
    E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
    E: Unable to lock directory /var/lib/apt/lists/
    W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
    W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

    ReplyDelete
  34. Hi i am new to Kali, can someone please tell me how to resolve the following errors.I have tried the methods given in the article and i am posting the output below:

    root@DURGA:~# apt-get update && apt-get upgrade

    Fetched 15.4 MB in 38s (397 kB/s)
    Calculating upgrade... Done
    <------------Some warnings have been shortened due to space constraints------>

    supported-versions: WARNING! Unknown distribution: kali
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2016.2
    Setting up util-linux (2.29.1-1) ...
    insserv: warning: script 'K02cups' missing LSB tags and overrides
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package util-linux (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of sysvinit-utils:
    sysvinit-utils depends on util-linux (>> 2.28-2~); however:
    Package util-linux is not configured yet.

    dpkg: error processing package sysvinit-utils (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    util-linux
    sysvinit-utils
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    ReplyDelete
  35. root@DURGA:~# apt-get update && apt-get upgrade
    Get:1 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease [30.5 kB]
    <------some warnings have been removed due to space constraints--------------------------->
    1497 upgraded, 0 newly installed, 0 to remove and 553 not upgraded.
    7 not fully installed or removed.
    Need to get 843 MB of archives.
    After this operation, 90.9 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 libaudit-common all 1:2.6.7-1 [17.9 kB]

    Installing new version of config file /etc/init.d/hwclock.sh ...
    insserv: warning: script 'K02cups' missing LSB tags and overrides
    insserv: warning: script 'cups' missing LSB tags and overrides
    insserv: Starting cups depends on rc.local and therefore on system facility `$all' which can not be true!
    insserv: Starting cups depends on rc.local and therefore on system facility `$all' which can not be true!
    insserv: Starting cups depends on rc.local and therefore on system facility `$all' which can not be true!
    insserv: There is a loop between service cups and rc.local if started
    insserv: loop involving service rc.local at depth 8
    insserv: loop involving service cups at depth 1
    insserv: Starting cups depends on rc.local and therefore on system facility `$all' which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing package util-linux (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    util-linux
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    root@DURGA:~# apt-get update --fix-missing
    Hit:1 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease
    Reading package lists... Done


    The error continues...Pl help

    ReplyDelete
  36. my kali is not updating . it stops after this line Reading package lists ...
    i have kali 2016.1

    ReplyDelete
  37. my kali is not updating it stops after reading packages list and i have kali 2016.1 please help sir.

    ReplyDelete
    Replies
    1. Fix your sources.list Repositories file
      Check the link below
      Fix Kali Linux sources.list Repositories
      http://www.kalitut.com/2014/06/fix-kali-linux-sourceslist-repositories.html

      Delete
  38. eading package lists... Done
    E: The repository 'http://dl.google.com/linux/chrome/deb stable Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: The repository 'http://security.kali.org/kali-security sana/updates Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: The repository 'http://http.kali.org/kali sana Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: The repository 'http://security.kali.org/kali-security kali/updates Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: The repository 'http://http.kali.org/kali kali Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    ReplyDelete
  39. Whenever I try to use upgrade command .... It says....
    Could not open lock file /var/cache/apt/archives/partial failed

    And
    Just
    Could not open lock file
    Unable to lock directory


    Please help ..... Thank-you in advance

    ReplyDelete
    Replies
    1. open kali linux terminal and then do the following
      sudo -s
      apt-get update
      apt-get upgrade

      Delete
    2. if that doesn't work try the following
      Open a terminal and run the following commands (please be sure to us sudo!):
      sudo mkdir -p /var/cache/apt/archives/partial
      sudo touch /var/cache/apt/archives/lock
      sudo chmod 640 /var/cache/apt/archives/lock

      Then try to update and upgrade

      Delete

[blogger]

Author Name

{picture#YOUR_PROFILE_PICTURE_URL} YOUR_PROFILE_DESCRIPTION {facebook#https://www.facebook.com/wTsXDev} {twitter#https://twitter.com/wTsDev} {google#https://plus.google.com/u/0/+AnonSalame} {pinterest#https://www.pinterest.com/Thexwts/} {youtube#https://www.youtube.com/channel/UCg2fUa8Yp-aWDCJYQTVHmBg}

Contact Form

Name

Email *

Message *

Powered by Blogger.